fbpx
Welcome, Guest
Username: Password: Remember me
{JFBCLogin}
25 Jan 2021
New boarders will have their posts moderated - Don't worry if you cannot see your post immediately.
Read More...
  • Page:
  • 1

TOPIC:

Need help with Audio/Video Sync 02 Dec 2022 20:18 #123154

Hey folks!

I have an issue that is - literally - driving me nuts. I have a YouTube show that I record using a Canon M50 and a Rhode microphone. To date, I've recorded this show by connecting the microphone to the M50, recording directly to a capture card... ultimately removing the capture card from the camera, saving video clips to my harddrive, and ultimately editing them in FCPX.

This is a tedious process.

What I'd like to do is record directly to QuickTime (using the New Movie Recording) feature... selecting the Canon M50 as my video source and the Rhode microphone as my audio.

When I've tried this, I can successfully record a clip. For discussion purposes, let's say I record a 3 minute clip. When I view it in QuickTime, everything looks and sounds fine. The audio and video are synced from beginning to end without any issues.

Now, if I take that same exact file and dump it into FCPX for editing, something happens to the sync of audio and video. For the first 20 seconds or so, sync is fine. But then audio slowly starts to lag slightly behind. And by the time 3 minutes is reached, it's evident they are totally out of sync.

So frustrating.

I purchased Loopback and AudioHijack to attempt to alter the audio input time line, but it's not working. I've also tried export videos recorded using QuickTime as a different file type, but the sync issue still happens.

Is there something I'm doing wrong? A setting I can change? Getting this to work would be a HUGE time saver for me.

Any thoughts or ideas would be really welcomed!
Thanks, Todd

Please Log in to join the conversation.

Need help with Audio/Video Sync 02 Dec 2022 21:13 #123155

  • VTC
  • VTC's Avatar
  • Offline
  • Platinum Member
  • Platinum Member
  • Posts: 375
  • Karma: 1
  • Thank you received: 69
Atomos Connect 4K ($60) + OBS (Free) = Happy Dance
(Likely spent more than that in time & frustration to get failure.)

www.atomos.com/accessories/connect4k

obsproject.com

Please Log in to join the conversation.

Need help with Audio/Video Sync 02 Dec 2022 21:49 #123156

Ok… I downloaded OBS earlier today, but it doesn’t save videos in a format that FCP can read. Unless I’m doing something wrong?

Out of curiosity, what is Atomos Connect and why does it need to be used with OBS?

Please Log in to join the conversation.

Need help with Audio/Video Sync 02 Dec 2022 21:52 #123157

Ah… wait… I forgot to add:

My Canon M50 is connected to my computer using a CamLink 4K (which, I believe is similar to Atomos)

So, if I record Audio and video directly into OBS, how do save or export video clips to make them usable in FCP?

Please Log in to join the conversation.

Need help with Audio/Video Sync 03 Dec 2022 01:56 #123161

  • VTC
  • VTC's Avatar
  • Offline
  • Platinum Member
  • Platinum Member
  • Posts: 375
  • Karma: 1
  • Thank you received: 69
Misread your post. Only retained the Canon info and Youtube show info thinking you were trying to live stream while in fact you were recording THEN editing and audio was getting out of whack. Likely not a bit of information that's of value to you in my reply other than the more disparate devices you use the more thing can go awry.

I do something similar but gather everything in an Atomos Ninja V and go direct from SSD to timeline with everything synching fine. Since it's evident within the limites of a 3 minute capture I'd run a three minute test with the Canon on cam mic and eliminate the Rhode entirely to determine if the Rhode is screwing things up. Doesn't make sens it would but you never can tell.

Please Log in to join the conversation.

Need help with Audio/Video Sync 06 Dec 2022 09:03 #123201

Just to be on the safe side - have you checked that the audio sample rate is the same in both cases? And that the video frame rate is set identical? These two are the only ways I know of that will trow sync out on such a short clip. One of them (audio or video) is not playing back at the correct speed.

Please Log in to join the conversation.

Need help with Audio/Video Sync 06 Dec 2022 11:52 #123202

How do I set the frame rate to identical?

Please Log in to join the conversation.

  • Page:
  • 1