fbpx
Welcome, Guest
Username: Password: Remember me
{JFBCLogin}
25 Jan 2021
New boarders will have their posts moderated - Don't worry if you cannot see your post immediately.
Read More...

TOPIC:

Using "Space Bar" to playback clips in browser 18 Dec 2017 19:55 #92457

Is that problem fixed in FCPX 10.4?

Please Log in to join the conversation.

Using "Space Bar" to playback clips in browser 19 Dec 2017 11:24 #92489

What problem are you talking about?

Please Log in to join the conversation.

Using "Space Bar" to playback clips in browser 19 Dec 2017 12:14 #92491

If I press spacebar in browser window, it doesn't playback the video. Instead it brings "Video Roles/Audio Roles" checkboxes up.

This problem occurs if I've set keyboard access in System Preferences > Keyboard > Shortcuts, set Full Keyboard Access to “All Controls", which I prefs as in this way I can accept/reject different popup windows (which has Cancel/OK/etc. buttons) by using only keyboard.

Please Log in to join the conversation.

Using "Space Bar" to playback clips in browser 19 Dec 2017 12:25 #92493

I am afraid that is not a bug. It seems to be working as designed, even if that is not how you would expect.
When you set "All Controls" this alters how applications behave when you have this kind of views. All Cocoa applications behave this way. When your selection has a popup menu, space opens/closed the menu. Try it yourself, for example using the PDF popup on a print dialog.

Please Log in to join the conversation.

Using "Space Bar" to playback clips in browser 19 Dec 2017 12:45 #92496

It's been fixed.

Please Log in to join the conversation.

Using "Space Bar" to playback clips in browser 19 Dec 2017 12:50 #92498

  • JoeEditor
  • JoeEditor's Avatar
  • Offline
  • Platinum Member
  • Platinum Member
  • bbalser.com
  • Posts: 4923
  • Karma: 34
  • Thank you received: 702
Operating system level keyboard commands always take priority over application level keyword commands. It has always been this way.

Please Log in to join the conversation.

Last edit: by JoeEditor.

Using "Space Bar" to playback clips in browser 19 Dec 2017 13:08 #92501

  • Axel
  • Axel's Avatar
  • Offline
  • Platinum Member
  • Platinum Member
  • Posts: 568
  • Karma: 10
  • Thank you received: 74

Operating system level keyboard commands always take priority over application level keyword commands. It has always been this way.

I used to have my own workspaces *saved as* and have them added in >system preferences >keyboard >shortcuts >app shortcuts >Final Cut Pro with the exact names. Worked in 10.3, doesn't work now. Not a big deal though.

Please Log in to join the conversation.

Using "Space Bar" to playback clips in browser 19 Dec 2017 14:17 #92507

Operating system level keyboard commands always take priority over application level keyword commands. It has always been this way.

I used to have my own workspaces *saved as* and have them added in >system preferences >keyboard >shortcuts >app shortcuts >Final Cut Pro with the exact names. Worked in 10.3, doesn't work now. Not a big deal though.

Shortcuts are a valuable thing for me, so I had to try it.
It is still working here in 10.4 (shortcuts for sharing, and for workspaces, added in System Preferences). Make sure that the names are spelled exactly, and that the shortcuts you choose are not used for something else, either at the application or system level.

Please Log in to join the conversation.

Using "Space Bar" to playback clips in browser 19 Dec 2017 15:00 #92508

  • Axel
  • Axel's Avatar
  • Offline
  • Platinum Member
  • Platinum Member
  • Posts: 568
  • Karma: 10
  • Thank you received: 74
@lichinho.
Did that. Axels Color and Axels Browser surely don't exist elsewhere. And if I go over the top menu, everything looks the way I arranged it. Only if I use my shortcuts, FCP has forgotten how the windows were resized. Wrote feedback already.

Please Log in to join the conversation.

Last edit: by Axel.

Using "Space Bar" to playback clips in browser 19 Dec 2017 15:12 #92509

It appears you are saying something completely different then.
I had taken that the shortcuts were the problem, but now I see that the problem is Workspaces created in the previous version do not seem to work in the current one.
If that is the case, then it may be a bug. I have no such workspace to try. The one I created for testing (already in 10.4) is working, so maybe you have to recreate yours and that will hopefully work (annoying though it may be).

Please Log in to join the conversation.

Using "Space Bar" to playback clips in browser 20 Dec 2017 05:19 #92538

… that the problem is Workspaces created in the previous version do not seem to work in the current one.….

wot, really? <checking>, no, my own Workspaces before updating are avail and fully functional in 10_4....

Please Log in to join the conversation.

Using "Space Bar" to playback clips in browser 20 Dec 2017 09:06 #92543

  • Axel
  • Axel's Avatar
  • Offline
  • Platinum Member
  • Platinum Member
  • Posts: 568
  • Karma: 10
  • Thank you received: 74
My workspaces appear and are correct, but not available through system shortcuts. However, I can still go to >user >library >Application support >FinalCut Pro >Workspaces, duplicate and rename them to (exactly):
Factory 2 - Organize.moduleLayout
and
Factory 3 - Color & Effects.moduleLayout
... then replace the files in >applications >FinalCut Pro >show package contents> contents >ressources >workspaces.

With every FCP update, they are reset to default (as I have learnt), and I have to repeat the procedure.

Please Log in to join the conversation.

Using "Space Bar" to playback clips in browser 20 Dec 2017 13:38 #92559

My workspaces appear and are correct, but not available through system shortcuts. However, I can still go to >user >library >Application support >FinalCut Pro >Workspaces, duplicate and rename them to (exactly):
Factory 2 - Organize.moduleLayout
and
Factory 3 - Color & Effects.moduleLayout
... then replace the files in >applications >FinalCut Pro >show package contents> contents >ressources >workspaces.

With every FCP update, they are reset to default (as I have learnt), and I have to repeat the procedure.

Why, oh why are you doing that???!!!

I dare say that messing inside the application bundle is a big no no. It is surely unwarranted in this case.

Your own workspaces should be there where they were inside the appropriate folder under Application Support.

If you so much dislike the default workspaces provided by the application, fine, don't use them. Use your own. They appear in the menu, they can be associated with shortcuts, just not Command-0, etc, that are reserved.

Please Log in to join the conversation.

Using "Space Bar" to playback clips in browser 09 Jun 2019 20:27 #100181

Hello folks,
I'm new to this forum, so apologize in advance for my lack of understanding of the ins and outs...
I installed the new version of FCPX 10.4.4. Since doing so, the spacebar (or any other method) does not work to play back video or audio clips in the browser. I have tried every trick listed in the comments here, but nothing has worked. If I place the mouse cursor on any clip and press the space bar, the "view" label quickly flashes but nothing plays. I can set skimming for the timeline, but it does not stay activated in the browser.

Any more hints? Currently I have to throw everything into the timeline just to preview it. Obviously not any way to work.

Thank you for your help.

Please Log in to join the conversation.

Using "Space Bar" to playback clips in browser 09 Jun 2019 20:44 #100184

Hello again,

I had been having the spacebar issues with playing back any media in the browser.
After selecting the default window layout, I was able to play with the spacebar. I then created a new saved workspace, and all is working as before. So curiously after the update final cut was not able to use my preferred workspace, but now that I have created a new one after updating to q0.4.4 all is good.
I hope perhaps this helps someone else having these issues.

Please Log in to join the conversation.

Using "Space Bar" to playback clips in browser 10 Jun 2019 14:53 #100190

  • dgwvideo
  • dgwvideo's Avatar
  • Offline
  • Platinum Member
  • Platinum Member
  • Posts: 2142
  • Karma: 34
  • Thank you received: 285

I then created a new saved workspace, and all is working as before. So curiously after the update final cut was not able to use my preferred workspace, but now that I have created a new one after updating to q0.4.4 all is good.

It is recommended to trash preferences when running a new version of FCPX for the first time after any update (by holding Option AND Command when you launch the app). This likely would have solved your problem, but glad you got it working.
Creating history....one edit at a time !

Please Log in to join the conversation.

Using "Space Bar" to playback clips in browser 04 Oct 2020 22:02 #110344

Just noting that the "Space Bar" issue still exists in 10.4.10. This should have been resolved years ago. For anyone else looking here, I'm using the workaround where I turn off Audio Roles, Video Roles, Stereoscopic Mode and 360 Mode in list view. Someone had mentioned somewhere using "Tab" until the spacebar works again, but that workaround never worked for me. I tried deleting prefs and restarting as suggested here. That didn't help on my end.

Please Log in to join the conversation.

Using "Space Bar" to playback clips in browser 16 Nov 2020 07:20 #110888

I'm kinda having this issue too, i use the shorcuts that come with FPCX by default though. This is my work around:.
When i'm working in the timeline (shortcut command +2) and then, i want to move to the Browser window (Command + 1)
No matter how many times i press the space bar, the video or audio wont play, using tab until the space works, doesnt work either.
So the only way to play clips in the Browser after using the shorcut (Command +1) is to use the L key to Play/move forward.
The K key, to stop, and the J key, to go backwards

Please Log in to join the conversation.

Using "Space Bar" to playback clips in browser 11 Sep 2022 07:17 #122133

OOOOOOF! 2022 and still having this issue with not being able to use the spacebar to play audio clips in the browser. Any guesses at why, of all things, this one wasn't squashed years ago? It seems like one of the far more basic fixes.

Files should preview in the browser with the spacebar just like they did way back (and occasionally do now). L is fine for the timeline, but not in the browser. It's not intuitive. I'm going down the a list of audio files now. When I click the spacebar, the carrot (triangle) turns and shows the associated keywords 🙄. This function is similar to what the right arrow would do in finder.

Please Log in to join the conversation.

Using "Space Bar" to playback clips in browser 11 Sep 2022 10:31 #122134

Did you try trashing your preferences? Not sure how your application is laid out but it should work correctly with audio or video.

Please Log in to join the conversation.