Welcome, Guest
Username: Password: Remember me
25 Jan 2021
New boarders will have their posts moderated - Don't worry if you cannot see your post immediately.
  • Page:
  • 1


Help! I cannot open my library! 12 May 2017 13:30 #88010

FCPX suddenly crashed and now I cannot open my library or any of the backups of that library. The library is located on an external drive.
I can open other libraries on my local drive as well as on the external drive, so my fear is that the library is corrupt.

What I have tried so far:
- Reboot + ejected external drives
- Checked the drive and Library permissions (both read/write)
- Trashed the hidden lock-dir folder
- Trashed the CurrentVersion.flexolibrary file

But it still doesn't work.

Any ideas?

FCPX 10.3.3
MacOS 10.12.4

Please Log in to join the conversation.

Help! I cannot open my library! 13 May 2017 14:46 #88018

Hi again,

Here's an update, just for the record.

I have been on the phone with apple for hours and they think it's a corrupted library. That is not completly uncommon according to them, especially with larger libraries. But it becomes a huge problem when the backups get affected as well. That sounds like an imperfect backup system to me.
They suggested I should make copies of the entire Library regulary - which kind of makes sense - but I would have to do this at least two times a day if I cannot rely on the FCPX-backups, and when the Library grows big it would become quite time consuming.
Time Machine is the way to go I guess, but unfortunately in my case the Library sits on an external drive which hasn't been Timemachined.

I am now trying to save some of the Events by copying them into a new Library. i.e. from the finder window opening the Library with "Show package content". But my "main" Event remains lost and unfortunately that's where 80% of my work has been done.
I'll keep trying to find a solution. Losing 6 weeks of work is not an option.

Am I the only one who has experienced a corrupted Library?

Can anyone tell me if there is a way to locate a corrupt file?


Please Log in to join the conversation.

Help! I cannot open my library! 14 May 2017 14:51 #88044

Hi again,

After 48 desperate hours I have found a solution! (at least for now).

Seems like I'm having a conversation with myself here, ;) but I thought I'd write this down in case someone else encounter a similar issue.

I'm not sure if this is the best way to do it or if it's even recommended, but this method worked for me.

1. Locate the corrupt Event (the Event where the corrupted file/clip lives):

- In FCPX create a clean/new Library and close it again.
- Open the corrupted Library in Finder as "Show package contents" (Right/control-click)
- Copy all files and folders plus ONE OF THE Event folders and paste it at the corresponding location in the clean Library. Click "Replace" when popup window shows.
- Open the new Library in FCPX. If it opens and the Event looks OK it means that this is NOT the corrupted Event.
- Repeat above (Always start off with a clean Library) until you encounter the Event that won't open. Then you have found the corrupted Event!

2. "Fix" the corrupt Event:

- Create a new Library again and then you create an Event within that Library that you name EXACTLY as the corrupt Event in your original Library. Then close FCPX.
- In Finder go to your original Library and "Show package contents" and locate the folder of the corrupted Event. Copy all folders within the Event folder (Original Media, Render Files, Transcoded Media) EXCEPT the CurrentVersion.fcpevent file and paste them at the corresponding location in your clean Library.
- Then go to the backups of original Library (Default: Home/Movies/Final Cut Backups) and locate the latest backup, open as "Show package contents" and locate the CurrentVersion.fcpevent file in the corresponding Event folder and copy that file to the same location in your new Library.
- Open new Library in FCPX and the corrupt Event should open.

NB. This isn't a solution for finding and removing the corrupt file, but at least now I can access the work I've done.
Hopefully some smart people will come up with a tool that can restore corrupt Libraries. Like Digital Rebellion's "Pro Maintenance Tool" which as far as I know doesn't repair FCPX-libraries.

Hope this made sense and can be of any help.


Please Log in to join the conversation.

Help! I cannot open my library! 26 May 2023 04:14 #125642

6 years later and this post saved my life. I literally encountered the exact same problem. For some reason, one of my events seemed to get corrupted while my mac froze and I attempted to delete a project within my library. I suddenly could not open my library or any backups.

After two hours of troubleshooting I followed your guide step by step and was able to get my library to open.

The only thing was that now my projects were coming up with errors within the (working) library. So I followed a very similar approach.

I made the new library, made the new event with the same name as before, then I made a project with the same name. Then I copied over the currentversion.fcpevent file and the project suddenly appeared.

Thank you so much for saving my gigantic project today.

Please Log in to join the conversation.

Help! I cannot open my library! 28 May 2023 15:28 #125680

Wow, that's great. Thanks for letting me know. I didn't even remember this issue, it was so long ago.
I'm happy it helped you out.
Cheers, Stefan

Please Log in to join the conversation.

  • Page:
  • 1