fbpx
Welcome, Guest
Username: Password: Remember me
{JFBCLogin}
25 Jan 2021
New boarders will have their posts moderated - Don't worry if you cannot see your post immediately.
Read More...
  • Page:
  • 1

TOPIC:

Projects won't appear in FCPX 10.4.8 (Stupid choice beforehand) 04 Aug 2022 16:27 #121700

Hi.

So I have been dealing with this issue for quite a while and now I have finally decided to take it to the forums.

A few years back whilst on macOS High Sierra, I decided to install Final Cut Pro X on my iMac (27-inch, Late 2013) in order to perform video editing of my Drone footage. Unfortunately whilst about Final Cur Pro X online, I came across a video tutorial on installing FCPX 10.3.4 for free without paying nearly £300. I then stupidly proceeded to follow along with the tutorial and was able to install FCPX 10.3.4 for free via an online .dmg file.

A few years later in early 2020, I was preparing to update my iMac from macOS Mojave to macOS Catalina. At that time I had over 50 projects (Not inside an Event) created inside a Library I had created from the start. I then proceeded to update my iMac to macOS Catalina. Unfortunately, after having updated to that firmware I opened FCPX 10.3.4 and was greeted with a message saying that the developer of this app needs to update its firmware in order to work with this version of macOS. This error was understandable as of the loss of 32-bit support on Catalina. So I then decided to once again stupidly download a .dmg copy of FCPX from Safari this time FCPX 10.4.8 which was the recent version of FCPX at that particular time. Following the installation, I opened FCPX 10.4.8, loaded up the Library and was shocked to discover that all of my projects were not appearing and could not access them. I decided to open the "Package Contents" of the Library and I noticed that all of the Project Folders were inside and had the event files inside. Even the "Original Media" and "Transcoded Media" folder was there and had all of the video and audio files inside fully playing properly. One other thing I did notice was that no error appeared on FCPX 10.4.8 saying that the Library was damaged or corrupted. This would only appear if I had created an new event and deleted it from Finder. An error would then appear saying that the library is damaged and the deleted event could not be read. From that point onwards, I had spent the next to years trying to figure out the solution to this caused from a stupid decision. Literally, I had tried everything in the book:
  • - Tried moving projects into new Libraries and Events.
  • - Tried deleting the .flexolibrary file as if the Library was corrupted.
  • - Tried repairing the library using the "Project Repair" tool on "Digital Rebellion"
  • - Tried deleting and moving the event files in some of the projects.
  • - Tried deleting a small portion of project folders.
  • - Tried updating macOS Catalina firmware.
  • - Tried dual booting macOS Mojave and opening the Library using a trial version of FCPX 10.3.4 from online.
  • - Tried moving out each project folder one-by-one to see if one would load.
  • - Couldn't locate a Library backup or a Time Machine backup since I had not made one prior to what happened.
  • - Tried running First Aid on disk to see if anything needed fixing with the system.

So that was the Itinery of what I have tried in order to retrieve my projects. Nothing is working. FCPX 10.4.8 works well though. If a solution works for me I would be able to buy the proper £300 version of FCPX to prevent this from happening again and to teach me a lesson on not to install paid software for free on the internet. So does anyone have a solution or some ideas to this? This would be greatly appreciated. :)

FCPX VERSION: 10.4.8
macOS VERSION: Catalina 10.15.7
MODEL: iMac (27-inch Late 2013)
PROCESSOR: 3.2 GHz Quad-Core Intel Core i5
MEMORY: 8 GB 1600 MHz DDR3
GRAPHICS: NVIDA GeForce GT 755M 1 GB

Many Thanks.


FinTGM09

Please Log in to join the conversation.

  • Page:
  • 1