fbpx
fcp.co logo transparent
fcp clapperboard
Welcome, Guest
Username: Password: Remember me
{JFBCLogin}
25 Jan 2021
New boarders will have their posts moderated - Don't worry if you cannot see your post immediately.
Read More...
  • Page:
  • 1

TOPIC:

Unable to Move Library 02 Dec 2021 07:45 #117763

I am currently trying to move one FCP library (roughly 500gb) from one external hard drive to another (both drives formatted MacOS Extended), and every time I do the transfer gets about half way done then I receive a message saying "the operation can't be completed because the item is in use." I'm not sure how the item can be in use if FCP is not even running. I have tried moving the library to multiple different drives, copy paste, drag and drop, nothing works. I opened a backup file of the library and tried to move it and got the same message. Has anyone else encountered this issue? I have been using FCPX for 9 years and have never had this happen before. Someone please help.

Please Log in to join the conversation.

Unable to Move Library 02 Dec 2021 12:47 #117771

Have you tried opening the library in FCP, creating a new library on the target drive and then copying each event into it (using FCP)? At least you might have a clue about which event contains the issue if FCP chokes at some point?

Please Log in to join the conversation.

Unable to Move Library 02 Dec 2021 15:33 #117773

  • joema
  • joema's Avatar
  • Offline
  • Platinum Member
  • Platinum Member
  • Posts: 2022
  • Karma: 27
  • Thank you received: 473
Empty the trash, make sure Finder is in list mode, not icon mode, then try again.

You don't see this problem very often. Unix-heritage filesystems do not generally have "mandatory" locking like Windows. That is why you normally don't see "file in use" errors. At the app layer the normal procedure is using "cooperative locking" where a hidden .lock file is used, called "advisory locking". Within a given app (like Finder) advisory locking might prevent certain operations. E.g, if Finder is building an icon cache or trying to generate thumbnails, in certain rare cases this might prevent a copy command, giving the above error.

You can also try using terminal to copy the library bundle (which is actually a folder tree):
www.macworld.com/article/222558/macos-co...-files-terminal.html

A simple example where I first created a destination folder in Finder (just in case), and the command was issued from the current folder where the library was. This uses -R to copy symlinks not resolve them and -v (verbose) to list each file as it is copied:

cp -R -v A7S3GradientTest.fcpbundle /Volumes/16TB_SSD/LibCopyTest

Please Log in to join the conversation.

Unable to Move Library 02 Dec 2021 20:22 #117779

thanks so much for the suggestion I didn't even think to do that and it definitely worked! much appreciated.

Please Log in to join the conversation.

  • Page:
  • 1